Promedio de temperatura y máximo-mínimo

Un conocido me pidió una mano para rendir una materia, y por él conocí el entorno PseInt con muchas facilidades para enseñar y aprender a programar. Aquí publico un ejercicio que hicimos con un vector.

El problema que planteamos, fué cargar una temperatura por hora en el día, una vez completado, promediarlas y encontrar la máxima y la mínima.

diagrama de flujo

Se debe configurar el lenguaje como flexible.

Proceso Cargar_vector
//    Carga las temperaturas, las promedia, muestra el maximo y el minimo.

//Creamos el vector
Dimension lista_Temperaturas(24)

//Cargamos el vector de temperatura
Para i<-1 Hasta 24 Hacer
escribir "ingrese temperaturas"
Leer lista_Temperaturas(i)
FinPara

//Sumamos las temperaturas, buscamos el maximo y el minimo
minimo=lista_Temperaturas(1)

Para i<-1 Hasta 24 Hacer

suma=suma+lista_Temperaturas(i)

Si lista_Temperaturas(i) > maximo Entonces
maximo=lista_Temperaturas(i)
Fin Si

Si lista_Temperaturas(i) < minimo    Entonces
minimo=lista_Temperaturas(i)
FinSi
FinPara

//Imprimimos los resultados
escribir "El promedio de temp es " suma/24
escribir "La temp maxima es: " maximo
Escribir "La temp minima es: " minimo
FinProceso

Espero que sea útil el ejercicio y compartan sus comentarios y ejercicios.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *